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Introduction

Scattering parameters or S-parameters are properties used in electrical engineering,
electronics engineering, and communication systems engineering describe the electri-
cal behavior of linear electrical networks when undergoing various steady state stimuli
by small signals. They are members of a family of similar parameters used in elec-
tronics engineering, other examples being: Y-parameters, Z-parameters, H-parameters,
T-parameters or ABCD-parameters [1][2]. Although applicable at any frequency, S-
parameters are mostly used for networks operating at radio frequency (RF) and mi-
crowave frequencies. S-parameters change with the measurement frequency so this must
be included for any S-parameter measurements stated, in addition to the characteris-
tic impedance or system impedance. S-parameters are readily represented in matrix
form and obey the rules of matrix algebra. Many electrical properties of networks or
components may be expressed using S-parameters such as gain, return loss, voltage
standing wave ratio (VSWR), reflection coefficient and amplifier stability. The term
‘scattering’ is more common to optical engineering than RF engineering, referring to

the effect observed when a plane electromagnetic wave is incident on an obstruction
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Figure 1: Typical schematic representation of an S-paramter data block.

or passes across dissimilar dielectric media. In the context of S-parameters, scattering
refers to the way in which the traveling currents and voltages in a transmission line
are affected when they meet a discontinuity caused by the insertion of a network into
the transmission line. This is equivalent to the wave meeting an impedance differing
from the line’s characteristic impedance.For a generic multi-port network definition, it
is assumed that each of the ports is allocated an integer n ranging from 1 to N, where
N is the total number of ports. For port n, the associated S-parameter definition is in
terms of incident and reflected ‘power waves’, a,, and by, respectively. There are two
available definitions of the wave variables in relation to the voltage and current vari-
ables (V;,, I,) when the reference impedances Zp, are complex valued — power wave
and pseudo wave. Following a definition by Kurokawa [3], the power wave formulation

defines
_ V,, + Z()*,nln _ V, — Z()*,nIn

in = VRe{Zon} n = VRe{Zon}
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On the other hand, the pseudo wave formulation [4] defines

_ Yot Zondn Vo = Zonln

When the port reference impedances are all real valued, the formulations become iden-
tical. For all ports the reflected power waves may be defined in terms of the scattering
matrix, or S-parameters, and the incident power waves by the following matrix equa-

tion:

where [S] is an N by N matrix the elements of which can be indexed using conventional
matrix (mathematics) notation.

Agilent Technologies, formerly Hewlett-Packard, is a leading manufacturer of
electronic test instruments. Vector Network Analyzer (VNA) has been one of the most
important test equipments for RF /microwave engineering. The results of a VNA mea-
surement are the S-parameters. There were two initial file formats used in HP VNA’s
called the Touchstone and CITI, respectively. Both formats are in ASCII text. With
the widespread adoption of S-parameters in other engineering areas, both Touchstone

and CITI formats have been adopted as the standard for exchanging S-parameters.

Remark 1 This tool assumes that Zg = 50 unless specified otherwise. If the initial

S-parameters have different portal impedance, a re-normalization should be applied.
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Figure 2: A schematic representation of the mixed-mode S-parameter data block.

0.1 Mixed-Mode S-Parameter

Differential signaling technique has been widely used in high-speed designs. In analyzing
the network behavior under the differential excitation, it is advantageous to convert the
regular network S-parameters to the so-called mixed-mode S-parameters [5][6][7]. For
the example network (N = 8) shown in Figure 2, the critical information is to define,
or keep track of the index mapping, the relationship between the differential (as well as
the common-mode) voltages. In this case, v41 = v1 — v2, Vg2 = V3 — V4, Vg3 = Us — Vs,
and vg4 = v7 — vg. An original network with 2M ports can be converted to a mixed-
mode S-matrix of the same rank. Typically, this rank-2M matrix is partitioned into

four block matrices, each of rank-M:

[SOO]MXM [Soe]MXM

[Seo]MXM [See]MXM
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0.2 Features of this tool

Read data from Touchstone or CITI files

e Derive Y, Z parameters for given S-parameters

e Perform mixed-mode conversion

e Write S-parameters to files

e Plots of S-parameter values (magnitude, phase, db, real or imaginary parts)

e Export plots to vector-based graphic formats (EPS and SVG)

e Export plots to raster graphic formats (PNG, JPG)

e Export plot data to ACSII files

vi
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e S-Parameter Explorer is written 100% in Java.

e The following Java numerical packages are instrumental building blocks:

— JFreechart: a comprehensive plotting package. URL: http://www.jfree.org

PtPlot: A plotting package as a part of the Ptolemy at UC Berkeley. URL:

http://ptolemy.berkeley.edu/java/ptplot/

Colt: a free Java toolkit at CERN for high performance computing. URL:

http://dsd.1bl.gov/ hoschek/colt/

JAMA (JAva MAtrix package): containss common matrix routines. URL:

http://math.nist.gov/javanumerics/jama/

— Jampack (JAva Matrix PACKage): matrix solver for complex matrices.

URL: ftp://math.nist.gov/pub/Jampack/Jampack/AboutJampack.html
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e This document is prepared with LaTeX
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1.1 Installation

The installer is distributed as a jar file (say install. SPEX1.0.jar), which should run on
any system with support of JavaTM (at least version 1.3). In modern operating system
like Windows XP, a double click should cause the installer to be launched automatically.
If not, user may open a prompt window, change directory to the location where the
installer resides, and type

java —jar install_.SPEX1.0.jar

The above command should also apply to any UNIX/Linux or Mac OS-X
system. After successful installation, there is a uninstall directory under the main
application directory. The jar file there can be used to remove the installed files, when
desired.

After installation, user need to add a shortcut to the desktop, which points
to the file named SPEX.bat in the application directory. Each time, the program can
be launched through this shortcut.

Note: This application requires support of JDK1.3 or higher.
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The Main User Interface

The main graphic interface provides controls by the user through elements such as lists

and buttons inside the main GUI panel area, and the menu items.

2.1 Parts of the Main GUI Panel Area

There are four portions inside the panel area (shown in Figure 2.1) labeled “Data
Module”, “Parameters”, “Value Filter”, and “Plot Components”. Each portion consists

of a list and some buttons. Functions of these elements are described below:

2.1.1 Data Module

The upper part of this portion is a list. Fach time, when a new S-parameter dataset

is read from a file, a new data module will be added to the list, with name derived
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Figure 2.1: Main GUI panel with four modules.

from the original data file. E.g., a file named “D:\temp\measl.s4p” will cause a data
module “measl” to be added to the list, once the file is successfully loaded through the

File: Open menu.

e Button “Rename”: can be used to change the name of the data module, provided

a module in the list is selected.

e Button “Mixed Mode”: can be used to derive the mixed-mode S-parameter corre-
sponding to the selected data module. Suppose the selected data module has 2M
ports, then a popup dialog will present a sequence of index numbers from 1 to 2M,
separated by comma. This defines the pairing of the differential ports as User can

freely alter the differential index pairing by changing the order of these 2M indices.
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E.g., if the original network has 8 ports. The default index pairing is as encoded
by “1,2,3,4,5,6,7,8” which implies vq1 = v1 — v2, Vg2 = V3 — V4, V43 = Vs — Vs,
and vg4 = v7 — vg. User may alter the encoded indices to “1,3,2,4,5,7,6,8” which
implies vg1 = vy — v3, Vg2 = V2 — V4, Vg3 = Vs — v7, and vg4 = ve — vg. The
only constraint is to make sure that the encoded indices are a permutation of the

original list of indices.

e Button “Delete”: can be used to remove a selected data module.

2.1.2 Parameters

The upper list part will display all the S-parameter elements for the selected data

module.

e Button “Derive Y”: can be used to derive the nodal-based admittance matrix, or

Y parameters. Y elements will be added to the list.

e Button “Derive Z”: can be used to derive the nodal-based impedance matrix, or

7 parameters. Z elements will be added to the list.

2.1.3 Value Filter

In general, the frequency-domain S, Y, and Z parameters are all complex-valued. Often,
the real-valued plots are preferred. The list provides the choices of filters (or functions)

that convert complex values to real values. The name “Real”, “Imag”, “dB”, “Magni-
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tude” and “Phase” are self-explanatory. Currently, the “Complex” keyword is not used

(in the future, this will used to organize a Smith Chart plot).

e Button “Add”: is used to add a selected (Data Module):(Parameter):(Value Fil-

ter) sequence to the next plot being prepared.

2.1.4 Plot Components

This part provides the necessary controls of composing a new plot.

e Button “Delete”: is used to delete the selected sequence.
e Button “Delete All”: is used to remove all sequences in the current list.

e Button “Plot All”: causes a new plot to be generated. Once a new plot is gener-
ated, it is beyond the control of the main GUI window. Please consult the section

on the “The Plotter Modules” for further information.

Once a plot is created, there are further manupulations available. Currently,
a plot can be generated with either JFreeChart (as shown in Figure 2.2) or PtPlot (as
shown in Figure 2.3) package. More details about plot manipulations are given in the

next chapter.
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Figure 2.2: Example plot created with JFreeChart package.
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Figure 2.3: Example plot created with PtPlot package.
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Plotting Utilities

3.1 Plotting Utility based on JFreeChart

In the standard JFreeChart distribution, there are certain built-in features for plot
manipulations. Among the choices of several plotting packages, mainly the XY data
plotting package is used in EE Circle tools. Enhancements are made to address the need
of various types of waveform display. Special efforts are made, based on the JFreeChart

API, to produce publication quality graphic files.

3.1.1 Features Come with JFreeChart

With a right mouse click on any part of the plot, a pop-up menu will be displayed

(Figure 3.1). It contains the following menu items:
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Figure 3.1: Upon a right mouse click anywhere on the plot, a pop-up menu appears.

e Properties: allows the user to configure many aspects of the plot properties.

Save As: allows the current plot to be saved in PNG format.

Print: allows the current plot to be sent to the printer.

Zoom In: allows zooming into either or both axes.

Zoom Qut: allows zooming out of either or both axes.

Auto Range: automatically sets the plotting ranges.

10
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Figure 3.2: The “Title” tab associated with the “Properties” pop-up menu item.

Pop-up Menu “Properties”

Once the “Properties” menu is selected, a dialog will be displayed. The dialog contains

three tabbed panes: (1) Title, (2) Plot, and (3) Other.

The “Title” Pane As shown in Figure 3.2, this allows the user to change the title

of the plot, including its font style and color.

11
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Figure 3.3: The “Plot” tab associated with the “Properties” pop-up menu item.

The “Plot” Pane As shown in Figure 3.3, this pane gives controls to the

labels of the X (domain) axis and the Y (range) axis. Also, user can change the bounds

of the two axes.

12
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Figure 3.4: The “Other” tab associated with the “Properties” pop-up menu item.

The “Other” Pane The “Other” pane, as shown in Figure 3.4 gives

additional controls over the plot attributes like background color, series and stroke

colors.

13
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Figure 3.5: The “Print” pop-up menu item.

Pop-up Menu “Print”

The plot can be rendered to a printer with this dialog as shown in Figure 3.5.

14
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Figure 3.6: The “Zoom in” pop-up memu item.
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Figure 3.7: The “Zoom out” pop-up memu item.

Pop-up Menu “Zoom In”

As shown in Figure 3.6, the plot can be zoomed in either X/Y or both axes.

Pop-up Menu “Zoom Out”

As shown in Figure 3.7, the plot can be zoomed out in either X/Y or both axes.
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Figure 3.8: The “Auto Range” pop-up memu item.

Pop-up Menu “Auto Range”

Fither the X or the Y axis, or both axes can be automatically adjusted to fit all data

points.

16
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Figure 3.9: A typical plot window.
3.1.2 GUI Features added by EE Circle

Additional GUI elements implemented are organized by regular menus. As shown in
Figure 3.9, there are four menus on the menu bar: (1) File, (2) Plot Control, (3) Eye

Mode, and (4) Window.

17
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Figure 3.10: The “File” menu of a plot.

The “File” Menu

As shown in Figure 3.10, the “File” menu have the following items:

e New: the current plot will be cleared. All data will be reset.

e Delimiter: allows the user to set/change the delimiter (token separator) used

for reading/writing text data files.

e Scaling: allow user to define a scaling factor for X or Y data. For instance, if
X-factor is set to le6, a sequence of x-values like {2.0e6, 3.0e6, 4.0e6, 5.0e6} will

be converted into {2.0, 3.0, 4.0, 5.0} after imported from a file.

e Import X Y Data: Any text data file in form of (X Y) or (X Y1 Y2 ...) can

be imported.

e Save Plot as: generate scalable or raster graphics files.

18
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Figure 3.11: The “Delimiter” item under the “File” menu of a plot.

e Export XY Data: save the data within the current plot into text file.

e Close: close the plot window.

The “Delimiter” Menu Item As shown in Figure 3.11, this allows the user to

conveniently choose a delimiter (column separator) for use with a text data file.

The “Scaling” Menu Item As shown in Figure 3.12, user is given the opportunity
of setting the scaling factors for X/Y data. Once ‘X Factor’ or ‘Y Factor’ is chosen, a

pop-up dialog will be displayed to receive a new scaling factor value.

19
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Figure 3.12: The “Scaling” item under the “File” menu of a plot.

The “Save Plot as” Menu Item As shown in Figure 3.13, there are three possible

graphic file formats supported:

e SVG: scalar vector graphics format. This is the most accurate representation of

the plot.

e PNG: portable network graphics format. This is a bit-mapped image format

that employs lossless data compression.

e JPG: This is the most popular raster format of graphics.

Remark 2 For user in need of the publication quality plots, it is highly recommended

to install an open source tool called Inkscape (http://www.inkscape.org/). Inkscape can

edit SVG file and export EPS file.

20
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Figure 3.13: The “Save Plot as” item under the “File” menu of a plot.

The “Plot Control” Menu

As shown in Figure 3.14, there are the following menu items:

X-Grid: The radio button toggled on/off to turn on the grid lines for X axis.

Y-Grid: The radio button toggled on/off to turn on the grid lines for X axis.

Log-X: The radio button toggled on/off to turn on the logrithmic axis for X.

Log-Y: The radio button toggled on/off to turn on the logrithmic axis for Y.

X NumPFormat: defines a number format for X-axis labels.

Y NumFormat: defines a number format for Y-axis labels.

X Bounds: sets the minimum, maximum and increment for X-axis.

Y Bounds: sets the minimum, maximum and increment for Y-axis.

21
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Figure 3.14: The “Plot Control” menu of a plot.

e Show Legend: legend can be turned on/off.

e Legend Position: legend placed at Right, Bottom, Left or Top of the plot.

e Curves: finer controls of the attributes of the curves.

22
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Figure 3.15: The pop-up dialog triggered by the “X NumFormat” item in the “Plot

Control” menu.

X/Y Number Format When either “X NumFormat” or “Y NumFormat” is se-

lected, a dialog similar to Figure 3.15 will be displayed.

A DecimalFormat pattern contains a positive and negative subpattern, for
example, " #,#4#0.00;(#,#+0.00)”. Each subpattern has a prefix, numeric part, and
suffix. The negative subpattern is optional; if absent, then the positive subpattern
prefixed with the localized minus sign (code>’-" in most locales) is used as the negative
subpattern. That is, 70.00” alone is equivalent to ”70.00;-0.00”. If there is an explicit
negative subpattern, it serves only to specify the negative prefix and suffix; the number
of digits, minimal digits, and other characteristics are all the same as the positive
pattern. That means that ”#,##0.0#;(#)” produces precisely the same behavior as
" # #H#0.04; (#,##0.04)”.

The prefixes, suffixes, and various symbols used for infinity, digits, thousands

separators, decimal separators, etc. may be set to arbitrary values, and they will appear

23
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properly during formatting. However, care must be taken that the symbols and strings
do not conflict, or parsing will be unreliable. For example, either the positive and
negative prefixes or the suffixes must be distinct for DecimalFormat.parse() to be able
to distinguish positive from negative values. (If they are identical, then DecimalFormat
will behave as if no negative subpattern was specified.) Another example is that the
decimal separator and thousands separator should be distinct characters, or parsing
will be impossible.

The grouping separator is commonly used for thousands, but in some coun-
tries it separates ten-thousands. The grouping size is a constant number of digits
between the grouping characters, such as 3 for 100,000,000 or 4 for 1,0000,0000. If
you supply a pattern with multiple grouping characters, the interval between the last

one and the end of the integer is the one that is used. So " #,## ##H#, #HHH#" ==

THAFHATAFHA == AHHHHFH

24
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Figure 3.16: Pop-up dialog for “X Bounds” item in the “Plot Control” menu.

X/Y Bounds A dialog like shown in Figure 3.16 will prompt the user with cus-

tomized values to fine tune the plot display.
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Figure 3.17: The radio button choices triggered by the “Legend Position” item in the

“Plot Control” menu.

Legend Position As shown in Figure 3.17, switching the position of the legend can

be achieved with one simple click.
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Figure 3.18: Pop-up dialog for the “Curves” item in the “Plot Control” menu.

Curves As shown in Figure 3.18, attributes of each curve (color, line property, and

symbol) can be individually adjusted through this dialog. A plot may contain multiple
curves, indexed starting 0. Only the curve of the selected index will have its attributes

updated.
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Figure 3.19: The “Eye Mode” menu.

The “Eye Mode” Menu

In modern digital applications, the quality of signal transmission from the driver to
the receiver is often characterized by an eye diagram. The menu “Eye Mode” provides
some basic facilities of converting a regular signal waveform into an eye diagram. The

following items are under this menu:

e Define UI: will display a dialog, as shown in Figure 3.20, for user to enter a

value for the unit interval (UI) or bit-time.

e Offset: will display a dialog, as shown in Figure 3.21, for user to enter a horizontal

offset for shifting the eye pattern.

e Y ref: will promt for a reference (re-centering) Y value, as shown in Figure 3.22.

e Generate Eye: trigger the generation of an eye diagram.
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Figure 3.20: Pop-up dialog for the “Define UI” item in the “Eye Mode” menu.
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Figure 3.21: Pop-up dialog for the “Offset” item in the “Eye Mode” menu.
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Figure 3.22: Pop-up dialog for the “Y ref” item in the “Eye Mode” menu.
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An example waveform and its corresponding eye diagram is displayed in Fig-

ure 3.23 and 3.24, respectively.
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Figure 3.23: An example waveform which may be folded into an eye diagram.
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Figure 3.24: The eye diagram view of the waveform data.

The “Window” Menu

The “Window” menu provide the user a means of switching between the regular wave-

form and eye diagram views.

Waveform
Eye Diagram

Figure 3.25: The “Window” menu in a plot.
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3.2 Plotting Utility based on PtPlot
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Figure 3.26: A plot window based on the PtPlot package.

In the upper part of the plotter panel, there are three buttons:

e Original: will resume the plot to its original view.

e Configure: allow user to configure various properties of the plot, such as the

title, axis titles, ranges of X and Y axes.

e Zoom Fit: will automatically calculate the ranges and capture all data points.

The PtPlot plotter has several menu items under the File menu:
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Figure 3.27: The “File” menu of a PtPlot plot.

Import X Y Data: allows the user to import additional text file (organized in

two columns separated by white space) and overlay with the current plot.

Save EPS: generates an encapsulated PostScript file.

Save PNG: generates a file in the Portable Network Graphics format.

Export Text: exports the data points of the current plot to several two-column
X]Y data file in pure text format. User can transfer such data into other appli-

cation for further processing or plotting.

Close: will close the current plot window.
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